Commit d80c4bf3 authored by Delaigue Olivier's avatar Delaigue Olivier
Browse files

v0.2.10.59 fix(htmlwidgets): startup message to warning about the version of htmlwidgets updated

Refs #5
parent 53f3a55f
Package: airGRteaching
Type: Package
Title: Teaching Hydrological Modelling with the GR Rainfall-Runoff Models ('Shiny' Interface Included)
Version: 0.2.10.58
Date: 2020-06-23
Version: 0.2.10.59
Date: 2020-10-15
Authors@R: c(
person("Olivier", "Delaigue", role = c("aut", "cre"), comment = c(ORCID = "0000-0002-7668-8468"), email = "airGR@inrae.fr"),
person("Laurent", "Coron", role = c("aut"), comment = c(ORCID = "0000-0002-1503-6204")),
......
......@@ -4,7 +4,7 @@
### 0.2.10.58 Release Notes (2020-06-23)
### 0.2.10.98 Release Notes (2020-10-15)
### Version control and issue tracking
......@@ -20,6 +20,11 @@
#### User-visible changes
- the <code>theme</code> agument of the <code>ShinyGR()<code> function now user partial matching
#### CRAN-compatibility updates
- when the package is loaded, a message warns the users if they use a version of 'htmlwidgets' < 1.5.2.9002. The latest version of this package, available on GitHub, avoids troubles with the use of dynamic graphics of the 'dygraphs' package (called by the <code>dyplot&#42;()</code> and the <code>ShinyGR()</code> functions)
____________________________________________________________________________________
......
.onAttach <- function(libname, pkgname) {
if (packageVersion("htmlwidgets") <= "1.5.1") {
if (packageVersion("htmlwidgets") <= "1.5.2") {
base::packageStartupMessage("\n---------------------------\n")
base::packageStartupMessage("This version of 'airGRteaching' is designed to work with 'htmlwidgets' >= 1.5.1.9000 (troubles with 'dygraphs')")
base::packageStartupMessage("This version of 'airGRteaching' is designed to work with 'htmlwidgets' >= 1.5.2.9000 (troubles with 'dygraphs')")
base::packageStartupMessage("Install the latest version of 'htmlwidgets' from GitHub with the following command lines:")
base::packageStartupMessage("\tinstall.packages(\"remotes\")\n\tremotes::install_github(\"ramnathv/htmlwidgets\")")
base::packageStartupMessage("\n---------------------------\n")
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment