Commit e3946f99 authored by Guillaume Perréal's avatar Guillaume Perréal
Browse files

Utilise pcov pour calculer le taux de couverture de code des tests.

parent 3c01ecff
include: include:
- project: pole-is/tools/ci-config - project: pole-is/tools/ci-config
ref: "1.9.0" ref: "1.10.0"
file: /php-package-ci.yml file: /php-package-ci.yml
- project: pole-is/tools/ci-config - project: pole-is/tools/ci-config
ref: "1.9.0" ref: "1.10.0"
file: /nodejs-ci.yml file: /nodejs-ci.yml
stages: stages:
......
...@@ -57,8 +57,9 @@ ...@@ -57,8 +57,9 @@
"irstea/phpmd-shim": "^2.7", "irstea/phpmd-shim": "^2.7",
"irstea/phpstan-config": "^1.1", "irstea/phpstan-config": "^1.1",
"jakub-onderka/php-parallel-lint": "^1.0", "jakub-onderka/php-parallel-lint": "^1.0",
"pcov/clobber": "^2.0",
"phpstan/phpstan-shim": "^0.11.15", "phpstan/phpstan-shim": "^0.11.15",
"phpunit/phpunit": "^7.3", "phpunit/phpunit": "^7.5",
"ramsey/uuid": "^3.8", "ramsey/uuid": "^3.8",
"ramsey/uuid-doctrine": "^1.5", "ramsey/uuid-doctrine": "^1.5",
"symfony/framework-bundle": "^3.4 | ^4.0", "symfony/framework-bundle": "^3.4 | ^4.0",
...@@ -67,6 +68,9 @@ ...@@ -67,6 +68,9 @@
"symfony/yaml": "^3.4 | ^4.0" "symfony/yaml": "^3.4 | ^4.0"
}, },
"scripts": { "scripts": {
"post-install-cmd": "@pcov-clobber",
"post-update-cmd": "@pcov-clobber",
"pcov-clobber": "@php vendor/bin/pcov . clobber",
"fix-cs": "@php vendor/bin/php-cs-fixer fix --verbose", "fix-cs": "@php vendor/bin/php-cs-fixer fix --verbose",
"phploc": "@php vendor/bin/phploc --no-interaction src/php tests", "phploc": "@php vendor/bin/phploc --no-interaction src/php tests",
"test": [ "test": [
...@@ -86,7 +90,7 @@ ...@@ -86,7 +90,7 @@
"test:phpcpd": "@php vendor/bin/phpcpd src/php tests --no-interaction --exclude=Fixtures/var", "test:phpcpd": "@php vendor/bin/phpcpd src/php tests --no-interaction --exclude=Fixtures/var",
"test:phpstan": "@php vendor/bin/phpstan analyse --no-progress --no-interaction", "test:phpstan": "@php vendor/bin/phpstan analyse --no-progress --no-interaction",
"test:composer-require-checker": "@php -d xdebug.max_nesting_level=1000 vendor/bin/composer-require-checker --ignore-parse-errors", "test:composer-require-checker": "@php -d xdebug.max_nesting_level=1000 vendor/bin/composer-require-checker --ignore-parse-errors",
"test:phpunit": "@php -d zend_extension=xdebug.so -d xdebug.coverage_enable=1 vendor/bin/phpunit --colors=never --coverage-text", "test:phpunit": "@php vendor/bin/phpunit --colors=never --coverage-text",
"test:console": "@php tests/Fixtures/console doctrine:schema:validate --ansi --skip-sync", "test:console": "@php tests/Fixtures/console doctrine:schema:validate --ansi --skip-sync",
"test:generate": "@php tests/Fixtures/console ng-model:generate -o output >/dev/null" "test:generate": "@php tests/Fixtures/console ng-model:generate -o output >/dev/null"
}, },
......
File suppressed by a .gitattributes entry or the file's encoding is unsupported.
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment